Welcome, Guest. Please login or register.

Author Topic: Ugh...problems...  (Read 1587 times)

BoxDude

  • Guest
Ugh...problems...
« on: June 01, 2009, 12:39:02 PM »
As if a cracked motor/tranny on a like-new bike isn't bad enough.........This morning I get on the bike to go to work and it won't start!  Won't even turn over.  I have power to everything else, but when I thumb the starter, nothing happens..even though I can see my lights dim with the drop in voltage.  C'mon Suzuki....I'm losing faith.

Offline Jay

  • mmm...beer
  • Administrator
  • Post Whore
  • *****
  • Posts: 5131
    • View Profile
    • jayt.org
Re: Ugh...problems...
« Reply #1 on: June 01, 2009, 05:01:40 PM »
As if a cracked motor/tranny on a like-new bike isn't bad enough.........This morning I get on the bike to go to work and it won't start!  Won't even turn over.  I have power to everything else, but when I thumb the starter, nothing happens..even though I can see my lights dim with the drop in voltage.  C'mon Suzuki....I'm losing faith.

Oh crap that sucks. Clutch pulled all the way in? Kick stand up? Just make sure you didn't forget the simple things.
-Jay

Offline Tim

  • Team Triumph
  • Pit Crew
  • Rossi Sr.
  • *****
  • Posts: 1960
    • View Profile
Re: Ugh...problems...
« Reply #2 on: June 01, 2009, 06:04:38 PM »
Oh crap that sucks. Clutch pulled all the way in? Kick stand up? Just make sure you didn't forget the simple things.
Like making sure the kill switch is in the run position, I've done that many times
2000 Honda VT1100 Sabre

"Looking for excuses to ride, not looking for excuses not to ride"

BoxDude

  • Guest
Re: Ugh...problems...
« Reply #3 on: June 01, 2009, 06:36:19 PM »
Haha yea, all that stuff was good.  After work I scoured all the fuses, wires, etc on the bike.  On a whim and a "what the hell" thought I disconnected and reconnected the clutch lever switch...started right up.  Must have been a bad contact;  odd how it could have happened overnight...

Offline Tim

  • Team Triumph
  • Pit Crew
  • Rossi Sr.
  • *****
  • Posts: 1960
    • View Profile
Re: Ugh...problems...
« Reply #4 on: June 01, 2009, 06:37:38 PM »
Suzuki's are strange little machines ;D
2000 Honda VT1100 Sabre

"Looking for excuses to ride, not looking for excuses not to ride"

Offline Jeff

  • Iron Butt
  • Pit Crew
  • Post Whore
  • *****
  • Posts: 5334
  • Expert Agitator
    • AOL Instant Messenger - GearHd6
    • View Profile
Re: Ugh...problems...
« Reply #5 on: June 01, 2009, 06:48:18 PM »
It ain't no Triumph!
-Jeff

2015 Triumph Tiger XCx
1998 Triumph Daytona T595
2004 Honda CRF250X

Offline Jay

  • mmm...beer
  • Administrator
  • Post Whore
  • *****
  • Posts: 5131
    • View Profile
    • jayt.org
Re: Ugh...problems...
« Reply #6 on: June 01, 2009, 07:25:27 PM »
It ain't no Triumph!
Yeah, thank God! :D
-Jay

Offline GerryP

  • Ice Cream in his Veins
  • Pit Crew
  • Rossi Sr.
  • *****
  • Posts: 1824
    • View Profile
    • Email
Re: Ugh...problems...
« Reply #7 on: June 01, 2009, 07:32:22 PM »
2015 Moto Guzzi V7 Stone (Red)

Motorcycling - It's not about what you ride or how fast you ride....is all about the ICE CREAM!!

Offline Jeff

  • Iron Butt
  • Pit Crew
  • Post Whore
  • *****
  • Posts: 5334
  • Expert Agitator
    • AOL Instant Messenger - GearHd6
    • View Profile
Re: Ugh...problems...
« Reply #8 on: June 01, 2009, 07:58:12 PM »
Yeah, thank God! :D

Yeah no kidding! Gerry and I are keeping that best kept secret to ourselves!
-Jeff

2015 Triumph Tiger XCx
1998 Triumph Daytona T595
2004 Honda CRF250X

BoxDude

  • Guest
Re: Ugh...problems...
« Reply #9 on: June 06, 2009, 12:01:21 PM »
Good news!  Finally stopped off at CTPower and Sport in Wallingford for them to take a look at my bike, and confirmed that the 'crack' was just some casting marks from manufacturing, and if it really were a crack then the oil pressure would make it leak all over the place.  It's what I have been thinking lately, since I have no loss in oil after cleaning up what I originally found - it must have been from an oil change.  This gives some good peace of mind now :), and I still have until September to completely fall apart under warranty lol.

Offline Jeff

  • Iron Butt
  • Pit Crew
  • Post Whore
  • *****
  • Posts: 5334
  • Expert Agitator
    • AOL Instant Messenger - GearHd6
    • View Profile
Re: Ugh...problems...
« Reply #10 on: June 06, 2009, 12:55:43 PM »
This gives some good peace of mind now :), and I still have until September to completely fall apart under warranty lol.

Oh it will!!! ;)



Good news though!
-Jeff

2015 Triumph Tiger XCx
1998 Triumph Daytona T595
2004 Honda CRF250X

Offline Jay

  • mmm...beer
  • Administrator
  • Post Whore
  • *****
  • Posts: 5131
    • View Profile
    • jayt.org
Re: Ugh...problems...
« Reply #11 on: June 07, 2009, 10:42:49 AM »
Oh it will!!! ;)

Coming from the guy with a British bike! >:D
-Jay

Offline Jeff

  • Iron Butt
  • Pit Crew
  • Post Whore
  • *****
  • Posts: 5334
  • Expert Agitator
    • AOL Instant Messenger - GearHd6
    • View Profile
Re: Ugh...problems...
« Reply #12 on: June 07, 2009, 12:11:38 PM »
Mine is 11 years old and going strong. :)
-Jeff

2015 Triumph Tiger XCx
1998 Triumph Daytona T595
2004 Honda CRF250X